$re = '/1(*COMMIT)2/m';
$str = '12 12 12 2 12 3 12 1 12 12 12 1 12 12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);