$re = '/\s*(?P<entity>([-\w]*\\\\){2}([-\w]*))(?:\s*)(?P<METHOD>([A-Z]*\|?)*)\s*(?P<SCHEME>(?4))\s*(?P<HOST>(?4))\s*(?P<PATH>.*)/m';
$str = '  App\\Entity\\Product-fetchAll     GET         ANY      ANY    /api/products
  App\\Entity\\Product-fetchOne     GET         ANY      ANY    /api/product/{id}
  App\\Entity\\Product-updateOne    PUT|PATCH   ANY      ANY    /api/product/{id}
  App\\Entity\\Product-createOne    POST        ANY      ANY    /api/product
  App\\Entity\\Product-deleteOne    DELETE      ANY      ANY    /api/product/{id}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);