import re
regex = re.compile(r"\s*(?P<entity>([-\w]*\\){2}([-\w]*))(?:\s*)(?P<METHOD>([A-Z]*\|?)*)\s*(?P<SCHEME>(?4))\s*(?P<HOST>(?4))\s*(?P<PATH>.*)", flags=re.MULTILINE)
test_str = (" App\\Entity\\Product-fetchAll GET ANY ANY /api/products\n"
" App\\Entity\\Product-fetchOne GET ANY ANY /api/product/{id}\n"
" App\\Entity\\Product-updateOne PUT|PATCH ANY ANY /api/product/{id}\n"
" App\\Entity\\Product-createOne POST ANY ANY /api/product\n"
" App\\Entity\\Product-deleteOne DELETE ANY ANY /api/product/{id}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")