import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*):\\s*Bus Number: Departure\\s*\\nBus code:\\s*([^ ]+)\\s([^ ]+)\\s([^\\n]+)[ \\t]*(?:\\n|$)((?:[^\\n]+\\n)+)?";
final String string = "KPN_Sleeper: Bus Number: Departure \n"
+ "Bus code: Kpn-866489 KA-01-7233 Bangalore dfdf\n"
+ "AC Sleeper/56 Seats\n"
+ "24 Seats booked \n\n"
+ "SRS: Bus Number: Departure \n"
+ "Bus code: SRS-5858 KA-31-5985 Bangalore dfdf dfd\n\n\n"
+ "SAM: Bus Number: Departure \n"
+ "Bus code: SAM-0077 TN-23-0777 Chennai ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}