re = /^(.*):\s*Bus Number: Departure\s*\nBus code:\s*([^ ]+)\s([^ ]+)\s([^\n]+)[ \t]*(?:\n|$)((?:[^\n]+\n)+)?/m
str = 'KPN_Sleeper: Bus Number: Departure
Bus code: Kpn-866489 KA-01-7233 Bangalore dfdf
AC Sleeper/56 Seats
24 Seats booked
SRS: Bus Number: Departure
Bus code: SRS-5858 KA-31-5985 Bangalore dfdf dfd
SAM: Bus Number: Departure
Bus code: SAM-0077 TN-23-0777 Chennai '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end