const regex = new RegExp('^(.*):\\s*Bus Number: Departure\\s*\\nBus code:\\s*([^ ]+)\\s([^ ]+)\\s([^\\n]+)[ \\t]*(?:\\n|$)((?:[^\\n]+\\n)+)?', 'gm')
const str = `KPN_Sleeper: Bus Number: Departure
Bus code: Kpn-866489 KA-01-7233 Bangalore dfdf
AC Sleeper/56 Seats
24 Seats booked
SRS: Bus Number: Departure
Bus code: SRS-5858 KA-31-5985 Bangalore dfdf dfd
SAM: Bus Number: Departure
Bus code: SAM-0077 TN-23-0777 Chennai `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}