package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)<\/level>(?:(?<taco16>.*?)(ActivityID='{(?<taco64>.*)}'))?(?<taco32>.*?)<Computer>`)
var str = `</Level><Task>...<Correlation ActivityID='{xxxx-xxx-xxxx-xxxx-xxxxx}'/><Execution...<Computer>
</Level><Task>...<Execution...<Computer>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}