$re = '/(?i)<\/level>(?:(?<taco16>.*?)(ActivityID=\'{(?<taco64>.*)}\'))?(?<taco32>.*?)<Computer>/m';
$str = '</Level><Task>...<Correlation ActivityID=\'{xxxx-xxx-xxxx-xxxx-xxxxx}\'/><Execution...<Computer>
</Level><Task>...<Execution...<Computer>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);