const regex = /(?i)<\/level>(?:(?<taco16>.*?)(ActivityID='{(?<taco64>.*)}'))?(?<taco32>.*?)<Computer>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)<\\\/level>(?:(?<taco16>.*?)(ActivityID=\'{(?<taco64>.*)}\'))?(?<taco32>.*?)<Computer>', 'gm')
const str = `</Level><Task>...<Correlation ActivityID='{xxxx-xxx-xxxx-xxxx-xxxxx}'/><Execution...<Computer>
</Level><Task>...<Execution...<Computer>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}