import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<title>.+)\\s+(?<text>[\\w\\W]+?)\\s*(?:---|$)";
final String string = "Automation Anxiety: Is Your Job Safe?\n\n"
+ "Many worry that AI will take over human jobs. However, the reality is more complex than simple replacement.\n\n"
+ "---\n\n"
+ "AI Will Disrupt Jobs, But Create New Ones\n\n"
+ "A shift is coming where many roles may be displaced. But new opportunities will also arise, balancing the job market.\n\n"
+ "---\n\n"
+ "AI Augments Human Potential\n\n"
+ "Instead of replacing individuals, AI enhances our work capabilities. It allows us to focus on creative and complex tasks that require human insight.\n\n"
+ "---\n\n"
+ "New Industries Will Emerge\n\n"
+ "The growth of AI will lead to unprecedented job opportunities. Fields like data science and machine learning will see increasing demand.\n\n"
+ "---\n\n"
+ "Prepare Yourself for an AI Future\n\n"
+ "Upskilling is essential to remain relevant in a changing job landscape. Emphasizing human skills like empathy and creativity will provide a competitive edge.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}