$re = '/(?<title>.+)\s+(?<text>[\w\W]+?)\s*(?:---|$)/m';
$str = 'Automation Anxiety: Is Your Job Safe?
Many worry that AI will take over human jobs. However, the reality is more complex than simple replacement.
---
AI Will Disrupt Jobs, But Create New Ones
A shift is coming where many roles may be displaced. But new opportunities will also arise, balancing the job market.
---
AI Augments Human Potential
Instead of replacing individuals, AI enhances our work capabilities. It allows us to focus on creative and complex tasks that require human insight.
---
New Industries Will Emerge
The growth of AI will lead to unprecedented job opportunities. Fields like data science and machine learning will see increasing demand.
---
Prepare Yourself for an AI Future
Upskilling is essential to remain relevant in a changing job landscape. Emphasizing human skills like empathy and creativity will provide a competitive edge.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);