# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<title>.+)\s+(?<text>[\w\W]+?)\s*(?:---|$)"
test_str = ("Automation Anxiety: Is Your Job Safe?\n\n"
"Many worry that AI will take over human jobs. However, the reality is more complex than simple replacement.\n\n"
"---\n\n"
"AI Will Disrupt Jobs, But Create New Ones\n\n"
"A shift is coming where many roles may be displaced. But new opportunities will also arise, balancing the job market.\n\n"
"---\n\n"
"AI Augments Human Potential\n\n"
"Instead of replacing individuals, AI enhances our work capabilities. It allows us to focus on creative and complex tasks that require human insight.\n\n"
"---\n\n"
"New Industries Will Emerge\n\n"
"The growth of AI will lead to unprecedented job opportunities. Fields like data science and machine learning will see increasing demand.\n\n"
"---\n\n"
"Prepare Yourself for an AI Future\n\n"
"Upskilling is essential to remain relevant in a changing job landscape. Emphasizing human skills like empathy and creativity will provide a competitive edge.\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.