#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "href="([^>]+)""
Local $sString = "<a id="link-1" href="/regexp-one">正则文章合集(All In One)</a>" & @CRLF & _
"<a id="link-2" href="/my-regexp">正则入门教程</a>" & @CRLF & _
"<a id="link-3" href="/deep-regexp">正则高级教程</a>" & @CRLF & _
"<a id="link-4" href="/regexp-lookaround">正则环视详解</a>" & @CRLF & _
"<a id="link-5" href="/php-curl">PHP cURL应用</a>"
Local $sSubst = "http://www.zjmainstay.cn$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)