#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<img[^>]+src="http:\/\/www\.example\.org\/image_to_be_removed\.jpg"[^>]*\>"
Local $sString = "<h1>Test article with HTML5 tags</h1>" & @CRLF & _
"<nav><a href="/link1/">Link 1</a></nav>" & @CRLF & _
"<p>This is an example article. The article may or may not include html5 tags, images and other things.</p>" & @CRLF & _
"<img src="http://www.example.org/image_to_be_removed.jpg">" & @CRLF & _
"<p>More example text.</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")