re = /<img[^>]+src="http:\/\/www\.example\.org\/image_to_be_removed\.jpg"[^>]*\>/m
str = '<h1>Test article with HTML5 tags</h1>
<nav><a href="/link1/">Link 1</a></nav>
<p>This is an example article. The article may or may not include html5 tags, images and other things.</p>
<img src="http://www.example.org/image_to_be_removed.jpg">
<p>More example text.</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end