import re
regex = re.compile(r"<img[^>]+src=\"http:\/\/www\.example\.org\/image_to_be_removed\.jpg\"[^>]*\>", flags=re.MULTILINE)
test_str = ("<h1>Test article with HTML5 tags</h1>\n"
"<nav><a href=\"/link1/\">Link 1</a></nav>\n"
"<p>This is an example article. The article may or may not include html5 tags, images and other things.</p>\n"
"<img src=\"http://www.example.org/image_to_be_removed.jpg\">\n"
"<p>More example text.</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")