#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([a-zA-Z0-9]+\.(jpg|png|gif|bmp|pdf))"
Local $sString = "cXdyORNyNzA0NDEzMjA9NmMmJSIiNTM2FjUyeHd4fg.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")