$re = '/^([a-zA-Z0-9]+\.(jpg|png|gif|bmp|pdf))/';
$str = 'cXdyORNyNzA0NDEzMjA9NmMmJSIiNTM2FjUyeHd4fg.pdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);