re = /^([a-zA-Z0-9]+\.(jpg|png|gif|bmp|pdf))/
str = 'cXdyORNyNzA0NDEzMjA9NmMmJSIiNTM2FjUyeHd4fg.pdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end