import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^urn:mystuff:v1:(ABC\\.(?!Acme).\\S+\\.\\S+\\.a\\d+\\.v\\d+|ABC\\.Acme\\.\\S+\\.a\\d+\\.\\d+\\.\\d+)$";
final String string = "urn:mystuff:v1:ABC.Test.MyData.a1.v1\n"
+ "urn:mystuff:v1:ABC.Acme.MyData.a1.0.1\n\n"
+ "urn:mystuff:v1:ABC.Acme.MyData.a1.v1\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}