const regex = /^urn:mystuff:v1:(ABC\.(?!Acme).\S+\.\S+\.a\d+\.v\d+|ABC\.Acme\.\S+\.a\d+\.\d+\.\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^urn:mystuff:v1:(ABC\\.(?!Acme).\\S+\\.\\S+\\.a\\d+\\.v\\d+|ABC\\.Acme\\.\\S+\\.a\\d+\\.\\d+\\.\\d+)$', 'gm')
const str = `urn:mystuff:v1:ABC.Test.MyData.a1.v1
urn:mystuff:v1:ABC.Acme.MyData.a1.0.1
urn:mystuff:v1:ABC.Acme.MyData.a1.v1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}