re = /^urn:mystuff:v1:(ABC\.(?!Acme).\S+\.\S+\.a\d+\.v\d+|ABC\.Acme\.\S+\.a\d+\.\d+\.\d+)$/m
str = 'urn:mystuff:v1:ABC.Test.MyData.a1.v1
urn:mystuff:v1:ABC.Acme.MyData.a1.0.1
urn:mystuff:v1:ABC.Acme.MyData.a1.v1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end