package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[ \t]*print\(.*`)
var str = `print("aaa")
#print("bbb")
# print("ccc")
def doSomething():
print("doSomething")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}