re = /^[ \t]*print\(.*/m
str = 'print("aaa")
#print("bbb")
# print("ccc")
def doSomething():
print("doSomething")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end