$re = '/^[ \t]*print\(.*/m';
$str = 'print("aaa")
#print("bbb")
# print("ccc")
def doSomething():
print("doSomething")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);