const regex = /^((?!([\w!#$%&'*+\-/=?\^_`{|}~]+(\.[\w!#$%&'*+\-/=?\^_`{|}~]+)*@((([\-\w]+\.)+[a-zA-Z]{2,4})|(([0-9]{1,3}\.){3}[0-9]{1,3})))).)*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!([\\w!#$%&\'*+\\-\/=?\\^_`{|}~]+(\\.[\\w!#$%&\'*+\\-\/=?\\^_`{|}~]+)*@((([\\-\\w]+\\.)+[a-zA-Z]{2,4})|(([0-9]{1,3}\\.){3}[0-9]{1,3})))).)*$', '')
const str = `Dogs welcome. We run a dog sanctuary alongside the house and have a example@example.com 2 acre fenced paddock which can be used for dog walking/training. Events must end by 11pm.You can find some details of the land`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}