$re = '/(\d)(?=(\d\d\d)+\b)/m';
$str = '1234567890';
$subst = "\1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;