import re
regex = re.compile(r"(\d)(?=(\d\d\d)+\b)", flags=re.MULTILINE)
test_str = "1234567890"
subst = "\\1,"
result = regex.sub(subst, test_str)
if result:
print(result)