import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Cycles Run: )\\d+|(?<= Current> )\\d+";
final String string = "00 LOG | Cycles Run: 120001\n"
+ "00 LOG ! Virtual: Max> 1082470400 bytes (1.0081 gb), Current> 640733184 bytes (0.5967 gb)\n\n"
+ "120001 \n\n"
+ "640733184";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}