import re
regex = re.compile(r"(?<=Cycles Run: )\d+|(?<= Current> )\d+", flags=re.MULTILINE)
test_str = ("00 LOG | Cycles Run: 120001\n"
"00 LOG ! Virtual: Max> 1082470400 bytes (1.0081 gb), Current> 640733184 bytes (0.5967 gb)\n\n"
"120001 \n\n"
"640733184")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")