$re = '/(?<=Cycles Run: )\d+|(?<= Current> )\d+/m';
$str = '00 LOG | Cycles Run: 120001
00 LOG ! Virtual: Max> 1082470400 bytes (1.0081 gb), Current> 640733184 bytes (0.5967 gb)
120001
640733184';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);