using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_[a-z]+_[a-z]+_\d{8}_\d*_";
string input = @"_HAM_MUC_24022017_100_
_HAM_MUC_24022017_100_
_gaexp
_gat_UA-35638432-1
intercom-id-c5ke8zbr";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}