package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)_[a-z]+_[a-z]+_\d{8}_\d*_`)
var str = `_HAM_MUC_24022017_100_
_HAM_MUC_24022017_100_
_gaexp
_gat_UA-35638432-1
intercom-id-c5ke8zbr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}