use strict;
my $str = '11111111112222222222333333333344444444445555555555666666666677777777778888888888999999999900000000000:
123:
23493278:
';
my $regex = qr/(?!^[^:]{100})(^[^:]+):$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}