import re
regex = re.compile(r"(?!^[^:]{100})(^[^:]+):$", flags=re.MULTILINE)
test_str = ("11111111112222222222333333333344444444445555555555666666666677777777778888888888999999999900000000000:\n"
"123:\n"
"23493278:\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")