$re = '/(?!^[^:]{100})(^[^:]+):$/m';
$str = '11111111112222222222333333333344444444445555555555666666666677777777778888888888999999999900000000000:
123:
23493278:
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);