#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(?<tagName>\w+)(?<attributes>.*)>(?<Value>.*)<\/\w+>" & @CRLF & _
""
Local $sString = "Dim SampleXML As String = $"<?xml version="1.0"?>" & @CRLF & _
"<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/">" & @CRLF & _
" <SOAP-ENV:Body SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:NS1="urn:wsNewGES2000Intf-IwsNewGES2000">" & @CRLF & _
" <NS1:PDA_DatosArticuloResponse xmlns:NS2="urn:wsNewGES2000Intf">" & @CRLF & _
" <NS2:PDADatosArticulo id="1" xsi:type="NS2:PDADatosArticulo">" & @CRLF & _
" <Codigo xsi:type="xsd:string">B1001</Codigo>" & @CRLF & _
" <Nombre xsi:type="xsd:string">PAT. LISA FAMILIAR 260 GRS X 12 B.</Nombre>" & @CRLF & _
" <Existencias xsi:type="xsd:double">0</Existencias>" & @CRLF & _
" <Costo xsi:type="xsd:double">1.2</Costo>" & @CRLF & _
" <Margen0 xsi:type="xsd:double">3</Margen0>" & @CRLF & _
" <PVP0 xsi:type="xsd:double">1.212</PVP0>" & @CRLF & _
" <Margen1 xsi:type="xsd:double">2</Margen1>" & @CRLF & _
" <PVP1 xsi:type="xsd:double">1.224</PVP1>" & @CRLF & _
" <Margen2 xsi:type="xsd:double">0</Margen2>" & @CRLF & _
" <PVP2 xsi:type="xsd:double">1.236</PVP2>" & @CRLF & _
" <Margen3 xsi:type="xsd:double">4</Margen3>" & @CRLF & _
" <PVP3 xsi:type="xsd:double">1.248</PVP3>" & @CRLF & _
" </NS2:PDADatosArticulo>" & @CRLF & _
" <return href="#1"/>" & @CRLF & _
" </NS1:PDA_DatosArticuloResponse>" & @CRLF & _
" </SOAP-ENV:Body>" & @CRLF & _
"</SOAP-ENV:Envelope>" & @CRLF & _
""$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")