import re
regex = re.compile((r"<(?<tagName>\w+)(?<attributes>.*)>(?<Value>.*)<\/\w+>\n"), flags=re.MULTILINE)
test_str = ("Dim SampleXML As String = $\"<?xml version=\"1.0\"?>\n"
"<SOAP-ENV:Envelope xmlns:SOAP-ENV=\"http://schemas.xmlsoap.org/soap/envelope/\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:SOAP-ENC=\"http://schemas.xmlsoap.org/soap/encoding/\">\n"
" <SOAP-ENV:Body SOAP-ENV:encodingStyle=\"http://schemas.xmlsoap.org/soap/encoding/\" xmlns:NS1=\"urn:wsNewGES2000Intf-IwsNewGES2000\">\n"
" <NS1:PDA_DatosArticuloResponse xmlns:NS2=\"urn:wsNewGES2000Intf\">\n"
" <NS2:PDADatosArticulo id=\"1\" xsi:type=\"NS2:PDADatosArticulo\">\n"
" <Codigo xsi:type=\"xsd:string\">B1001</Codigo>\n"
" <Nombre xsi:type=\"xsd:string\">PAT. LISA FAMILIAR 260 GRS X 12 B.</Nombre>\n"
" <Existencias xsi:type=\"xsd:double\">0</Existencias>\n"
" <Costo xsi:type=\"xsd:double\">1.2</Costo>\n"
" <Margen0 xsi:type=\"xsd:double\">3</Margen0>\n"
" <PVP0 xsi:type=\"xsd:double\">1.212</PVP0>\n"
" <Margen1 xsi:type=\"xsd:double\">2</Margen1>\n"
" <PVP1 xsi:type=\"xsd:double\">1.224</PVP1>\n"
" <Margen2 xsi:type=\"xsd:double\">0</Margen2>\n"
" <PVP2 xsi:type=\"xsd:double\">1.236</PVP2>\n"
" <Margen3 xsi:type=\"xsd:double\">4</Margen3>\n"
" <PVP3 xsi:type=\"xsd:double\">1.248</PVP3>\n"
" </NS2:PDADatosArticulo>\n"
" <return href=\"#1\"/>\n"
" </NS1:PDA_DatosArticuloResponse>\n"
" </SOAP-ENV:Body>\n"
"</SOAP-ENV:Envelope>\n"
"\"$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")