import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?<tagName>\\w+)(?<attributes>.*)>(?<Value>.*)<\\/\\w+>\n";
final String string = "Dim SampleXML As String = $\"<?xml version=\"1.0\"?>\n"
+ "<SOAP-ENV:Envelope xmlns:SOAP-ENV=\"http://schemas.xmlsoap.org/soap/envelope/\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:SOAP-ENC=\"http://schemas.xmlsoap.org/soap/encoding/\">\n"
+ " <SOAP-ENV:Body SOAP-ENV:encodingStyle=\"http://schemas.xmlsoap.org/soap/encoding/\" xmlns:NS1=\"urn:wsNewGES2000Intf-IwsNewGES2000\">\n"
+ " <NS1:PDA_DatosArticuloResponse xmlns:NS2=\"urn:wsNewGES2000Intf\">\n"
+ " <NS2:PDADatosArticulo id=\"1\" xsi:type=\"NS2:PDADatosArticulo\">\n"
+ " <Codigo xsi:type=\"xsd:string\">B1001</Codigo>\n"
+ " <Nombre xsi:type=\"xsd:string\">PAT. LISA FAMILIAR 260 GRS X 12 B.</Nombre>\n"
+ " <Existencias xsi:type=\"xsd:double\">0</Existencias>\n"
+ " <Costo xsi:type=\"xsd:double\">1.2</Costo>\n"
+ " <Margen0 xsi:type=\"xsd:double\">3</Margen0>\n"
+ " <PVP0 xsi:type=\"xsd:double\">1.212</PVP0>\n"
+ " <Margen1 xsi:type=\"xsd:double\">2</Margen1>\n"
+ " <PVP1 xsi:type=\"xsd:double\">1.224</PVP1>\n"
+ " <Margen2 xsi:type=\"xsd:double\">0</Margen2>\n"
+ " <PVP2 xsi:type=\"xsd:double\">1.236</PVP2>\n"
+ " <Margen3 xsi:type=\"xsd:double\">4</Margen3>\n"
+ " <PVP3 xsi:type=\"xsd:double\">1.248</PVP3>\n"
+ " </NS2:PDADatosArticulo>\n"
+ " <return href=\"#1\"/>\n"
+ " </NS1:PDA_DatosArticuloResponse>\n"
+ " </SOAP-ENV:Body>\n"
+ "</SOAP-ENV:Envelope>\n"
+ "\"$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}