package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)\%(?:\d+\.\d+)?[f|F]`)
var str = `Text %2.1f %2.2f %344.555f %erf %f`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}