$re = '/\%(?:\d+\.\d+)?[f|F]/ms';
$str = 'Text %2.1f %2.2f %344.555f %erf %f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);