const regex = /\%(?:\d+\.\d+)?[f|F]/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\%(?:\\d+\\.\\d+)?[f|F]', 'gms')
const str = `Text %2.1f %2.2f %344.555f %erf %f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}