import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "name:\\s*(\\S+).*?no:\\s*(\\d+)(?:.*?new:\\s*(yes))?.*?dob:\\s*(\\d{2}-\\d{2}-\\d{4}).*sal:\\s*(\\d+)";
final String string = "Name: abc\n"
+ " No: 1234\n"
+ "new: yes\n"
+ "DOB: 06-07-1992\n"
+ " sal: 40000";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}