re = /name:\s*(\S+).*?no:\s*(\d+)(?:.*?new:\s*(yes))?.*?dob:\s*(\d{2}-\d{2}-\d{4}).*sal:\s*(\d+)/i
str = 'Name: abc
No: 1234
new: yes
DOB: 06-07-1992
sal: 40000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end