package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{\{Template1 (.+?)\}\}`)
var str = `{{Template1 |Parameter1=Text |Parameter2=Text |Parameter3={{Template2|hier|steht|text}} |Parameter4=Text }}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}