re = /\{\{Template1 (.+?)\}\}/
str = '{{Template1 |Parameter1=Text |Parameter2=Text |Parameter3={{Template2|hier|steht|text}} |Parameter4=Text }}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end