const regex = /\{\{Template1 (.+?)\}\}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{Template1 (.+?)\\}\\}', '')
const str = `{{Template1 |Parameter1=Text |Parameter2=Text |Parameter3={{Template2|hier|steht|text}} |Parameter4=Text }}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}