using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{1,1000}\w*+";
string input = @"foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}