$re = '/.{1,1000}\w*+/ms';
$str = 'foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);