re = /.{1,1000}\w*+/m
str = 'foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo barbarbarbar bazbazbaz foo barbar bazbaz barbar fooo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end